Delibar doesn't launch on El Capitan

anders+delibar's Avatar

anders+delibar

30 Apr, 2016 09:25 AM

Hi,

I can't launch Delibar on El Capitan (newest version). I have updated to the newest version of Delibar also. I've attached the crash below.

Could your please look into this?

I'm running it on a 17" 2011 MacBook Pro 2.2 with 16 GB RAM.
---
Process: Delibar [44562]
Path: /Applications/Delibar.app/Contents/MacOS/Delibar
Identifier: net.shinyfrog.delibar
Responsible: Delibar [44562]
5 net.shinyfrog.delibar 0x0000e1ae 0x1000 + 53678
6 net.shinyfrog.delibar 0x0000b3ce 0x1000 + 41934
32 net.shinyfrog.delibar 0x000023a5 0x1000 + 5029
    0x1000 - 0x46fff +net.shinyfrog.delibar (1.6 - 212) <2426D1FE-D195-3796-8A7F-410ACEEAA96E> /Applications/Delibar.app/Contents/MacOS/Delibar
   0x58000 - 0x70fff +net.shinyfrog.SFToolkit (1.0) <D129CEEF-F65D-346D-9F5D-939575F6AC6C> /Applications/Delibar.app/Contents/Frameworks/SFToolkit.framework/Versions/A/SFToolkit
   0x81000 - 0x8ffff +net.shinyfrog.SFDeliciousApi (1.0) <B7D6EC9B-B874-3843-8D26-164FE8AE92AC> /Applications/Delibar.app/Contents/Frameworks/SFDeliciousApi.framework/Versions/A/SFDeliciousApi
   0x9b000 - 0xaefff +org.andymatuschak.Sparkle (1.5 Beta 6 - 313) <5DF2B8A3-560D-4500-6B85-4215644DE532> /Applications/Delibar.app/Contents/Frameworks/Sparkle.framework/Versions/A/Sparkle
   0xbf000 - 0xe1ff8 +com.parsekit.ParseKit (1.6b) <6381968A-76C1-375E-912A-E916CFE69ECA> /Applications/Delibar.app/Contents/Frameworks/ParseKit.framework/Versions/A/ParseKit
   0xf9000 - 0x10affb +net.hockeyapp.sdk.mac (1.0.3 - 13) <2300BA45-3A87-3B61-9CF8-09F3E2F919EF> /Applications/Delibar.app/Contents/Frameworks/HockeySDK.framework/Versions/A/HockeySDK
  0x115000 - 0x126fff +coop.plausible.CrashReporter (1.2-beta2) <D8184D0A-47A5-367E-BE4E-7E904B9E86C7> /Applications/Delibar.app/Contents/Frameworks/HockeySDK.framework/Versions/A/Frameworks/CrashReporter.framework/Versions/A/CrashReporter
0x9c45a000 - 0x9c505ff7 com.apple.LanguageModeling (1.0 - 1) <983C9467-801B-38C1-BE9C-8A8A5BD71F17> /System/Library/PrivateFrameworks/LanguageModeling.framework/Versions/A/LanguageModeling
0xb0000000 - 0xb0018ffb +com.binarymethod.BGHUDAppKit (1.0) <DF9CE8F9-DE9D-EDDD-F64B-8C315B24B3DE> /Applications/Delibar.app/Contents/Frameworks/BGHUDAppKit.framework/Versions/A/BGHUDAppKit
0xc0000000 - 0xc002cff3 +com.growl.growlframework (1.3.1 - 1.3.1) <E4CACCE9-3584-33AA-A2A3-2627C0BF4670> /Applications/Delibar.app/Contents/Frameworks/Growl.framework/Versions/A/Growl

  1. 1 Posted by anders+delibar on 30 Apr, 2016 09:28 AM

    anders+delibar's Avatar

    And I have tried deleting Delibar folder in ~/Library/Application Support.

  2. Support Staff 2 Posted by Danilo Bonardi on 01 May, 2016 04:59 PM

    Danilo Bonardi's Avatar

    Hi Andres,

    can you please send me the complete Delibar crash log ? Check this for finding it

    http://apple.stackexchange.com/questions/26480/where-can-i-find-my-...

    Cheers.

  3. 3 Posted by anders+delibar on 01 May, 2016 11:25 PM

    anders+delibar's Avatar

    Hi Danilo,

    It is attached.

    Anders

  4. Support Staff 4 Posted by Danilo Bonardi on 02 May, 2016 07:26 AM

    Danilo Bonardi's Avatar

    Hi,

    please try to delete Delibar preference file here:

    ~/Library/Preferences/net.shinyfrog.delibar.plist

    and restart Delibar.

    Cheers.

  5. 5 Posted by anders+delibar on 02 May, 2016 07:46 AM

    anders+delibar's Avatar

    Hi,
    After deleting the prefs, it started, and I re-added the account. And then it crashed again. Then I restarted it again and the account was added (in the Accounts tab of the Settings), but it showed I have no bookmarks. When I press the "Reload all active accounts" button it crashes again. I've attached a crash log.

  6. Support Staff 6 Posted by Danilo Bonardi on 02 May, 2016 04:03 PM

    Danilo Bonardi's Avatar

    Hi,

    you can try with this version
    https://dl.dropboxusercontent.com/u/18612911/Delibar.app.zip

    But I forgot to warn you we are having issues with Delicious severs. They broke something on their side and does not respond to our support requests.
    Please contact them at [email blocked] and ask to fix their API servers.

    Cheers.

  7. 7 Posted by anders+delibar on 03 May, 2016 08:20 AM

    anders+delibar's Avatar

    Hi,

    Thanks, now the app doesn't crash. But it still doesn't work - none of my bookmarks show up inside Delibar.

  8. 8 Posted by hhprintemps on 07 May, 2016 03:46 PM

    hhprintemps's Avatar

    This comment was split into a new discussion: Image2icon

    Hi,
    I am french; I bought Image2icon to put my icon on Mac- applications, because since I am on el Capitan, The system must be better protected and t's blocked,
    Please, help me and tell me what to do with your process !!

    Thank you,
    HH

  9. Konstantin Erokhin closed this discussion on 17 Nov, 2016 02:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac