Markdown format for Picture

Xiyu Liang's Avatar

Xiyu Liang

22 Sep, 2016 08:25 AM

Firstly, as a non-native English speaker, I don't know how to properly show my respect and gratitude to your great work. Please accept my apologies.

There is one thing I cannot understand in Bear's beta version for Mac.
It seems that it doesn't support the markdown format for picture. It can only insert a picture by drag&drop or paste.
For example, ![Pic]( should be able to add a picture to most markdown editors.
Many of them would not show it directly, however, they will add the picture into the document while exporting. Some editor like Typora would directly show the picture.
Considering that Bear support live preview, I suppose this kind of support is very important. Cause I'm using an app called iPic on my Mac, it would automatically generated a code like ![Pic]( after I uploaded a picture. Then I can easily paste it into any markdown editor. Why not Bear?
I guess, at least Bear should add the picture into documents while exporting.
Hope to hear your voice regrading this issue.

BTW, I haven't got the beta version for iOS devices. If possible, could you please help me to get it? Thank you very much.

Best regards,
Xiyu Liang
[email blocked]

  1. Support Staff 1 Posted by Danilo Bonardi on 23 Sep, 2016 08:27 AM

    Danilo Bonardi's Avatar


    yes, we'll introduce a syntax highlighting similar to the current links for markdown images syntax. Hopefully before the 1.0 release.


  2. 2 Posted by Klein on 19 Oct, 2016 02:09 PM

    Klein's Avatar

    Is this still on track?

  3. Support Staff 3 Posted by Danilo Bonardi on 20 Oct, 2016 08:01 AM

    Danilo Bonardi's Avatar


    the markdown image syntax highlight is available in Bear beta 4, but only if you have the markdown mode on.


  4. 4 Posted by Walter on 22 Dec, 2016 08:31 PM

    Walter's Avatar

    I'm using Bear v1.0.4 and I can't get an image to display. Example: `![web-image](` . Is this markdown syntax supported?

  5. Support Staff 5 Posted by Danilo Bonardi on 23 Dec, 2016 01:58 PM

    Danilo Bonardi's Avatar


    markdown image syntax is highlighted if the markdown mode is enabled but not displayed as an inline image.

    In the 1.0.5 release markdown images will be highlighted even if the markdown mode is off.


  6. 6 Posted by Gordon Erlebach... on 07 Oct, 2017 08:05 PM

    Gordon Erlebacher's Avatar

    This comment was split into a new discussion: Markdown format for Picture


    I am using Bear version 1.3.1. I inserted an image into one of my notes using shift-cmd-V. When I export the note (I do not have the pro version) to rtf format, the image is lost.
    Why is that? Does not seem reasonable since rtf format does support images.

    I also looked at the notes in the "Marked 2" application (version 2.5) and the image does not show. Is this expected behavior?

    Finally, is the image actually contained in the note, or does the note simply contain a pointer to the image? Looking at the html generated by "Marked 2", I see:

    <p><img src="assets/assets/Screen%20Shot%202017-10-07%20at%203.21.23%20PM.png" alt="" /><br/>

    Yet, the image was in Desktop.

    From Bear, I clicked on the image, and did a copy as Markdown, and got:


    The image file name is correct; however, the image was in a different directory. Why don't you use the full path for the image? Thanks.

    Finally, if the image is moved on my desktop to another folder, will the note break or will the file movement be tracked?



  7. 7 Posted by Miel on 11 Mar, 2018 12:54 PM

    Miel's Avatar

    Im looking forward for this issue to be answered im torn between bear and ulysses but because of this missing feature I may opt in for ulysses

  8. Support Staff 8 Posted by Danilo Bonardi on 11 Mar, 2018 03:45 PM

    Danilo Bonardi's Avatar

    @Miel You mean the issue expressed by Gordon? Should be fixed in the current versions.

  9. 9 Posted by Miely Echon on 12 Mar, 2018 02:40 AM

    Miely Echon's Avatar

    I'm trying to add image from external source/ image link from an image host
    using the ![alt](url) but it doesn't work. I thought it would appear if
    I'll export it to html after editing the whole thing but it doesn't show an
    html for that.

  10. Support Staff 10 Posted by Danilo Bonardi on 12 Mar, 2018 11:27 AM

    Danilo Bonardi's Avatar

    You should see ![alt](url) highlighted in your note and when exported into HTML should result in something like this

    <p><img src="url" alt="alt" title=""></p>

    Maybe check if the "url" part is correct.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac