Tell Bear to stop recognizing certain text as a hyperlink?

Lisa's Avatar


12 Sep, 2016 07:29 PM

I often use bear for drafting text before I drop it in its final home (like a web page or shared document). Sometimes, the things I writing include addresses and/or URL; for example, I'm writing invitation text right now, which has both. Unfortunately, Bear these into links — and I keep inadvertently clicking on them, which always opens a pop-up and an app, that I then have to close.

I would love to have a way to right-click on a URL, address, or anything else that Bear automatically turned into a hypertext and say, "This is not a link." Email apps and Google Docs have this ability.

Alternatively, I'd like the ability to tell Bear, "Please don't look for hypertext in this given note."

  1. Support Staff 1 Posted by Danilo Bonardi on 13 Sep, 2016 07:34 AM

    Danilo Bonardi's Avatar

    Hi Lisa,

    if I understand correctly, you don't want URLs to turn into markdown links, you can check Bear preferences and disable "Auto fill title when pasting web address".


  2. 2 Posted by Raul on 03 Nov, 2017 07:47 PM

    Raul's Avatar

    Turning off "Auto file title when pasting web addresses" did not work. Even stopping closing the app and restarting it.

  3. 3 Posted by bobinnv on 04 Nov, 2017 04:57 PM

    bobinnv's Avatar

    I have a similar issue - I have a list in the form "date first initial last name, zip code" and for some reason one item gets underlined with the little map icon put in front of it, and clicking on it brings up a map with some components of the item - it would be great if there was a way to tell Bear not to attempt to find any links or URLs

  4. 4 Posted by jm on 14 Nov, 2017 01:03 PM

    jm's Avatar

    Ditto. This is incredibly irritating. I’m composing (on ipad) text to send for a print publication. This includes an address and Bear auto adds a little location icon and hot links the address. I have to instruct the printer to ignore the icon and link underlining. It’s impossible to remove the icon or hotlink, and additionally whenever I touch the text it opens Apple maps, which wastes time and makes it harder to edit the text.

    Separately, the Setting toggle shown by Danilo is not available on the iPad version.

  5. 5 Posted by Leslie on 24 Jan, 2018 10:33 PM

    Leslie's Avatar

    Honestly, this is completely ruining Bear for me. How do you turn this "feature" off?

    No matter what I do it always auto formats the link with no easy way to undo it. If I turn off "auto complete" it still does it. I just want to do this:

    [Some Link Title](Paste Link here)

    And not have Bear mess with it. Sometimes these links are 30+ characters long. When I paste that in, it never just does what I expect - replace the text with the link and nothing else.

    Right now here is what Bear does:

    [Some Link Title]([Page header as title](link))

    And then I have to carefully use the arrow keys to undo everything thing.

  6. Support Staff 6 Posted by Danilo Bonardi on 25 Jan, 2018 02:13 PM

    Danilo Bonardi's Avatar

    Hi Leslie,

    just to be sure, have you disabled the preference in the screenshot?
    Because if it still completes your links is a bug.


  7. 7 Posted by Jean-Marc Le Ti... on 25 Jan, 2018 06:15 PM

    Jean-Marc Le Tissier's Avatar

    The problem is that this preference option does not appear anywhere in Bear iOS

  8. Support Staff 8 Posted by Danilo Bonardi on 26 Jan, 2018 10:20 AM

    Danilo Bonardi's Avatar

    I don't understand, this functionality is always turned off on iOS.

  9. 9 Posted by Jean-Marc Le Ti... on 26 Jan, 2018 03:24 PM

    Jean-Marc Le Tissier's Avatar

    At the time I raised this, copy and pasting a geographical address from, say a webpage into Bear created a hyperlink that could not be unlinked. I tried again just now (on iPhone) and this no longer creates a hyperlink.

    However, copying a URL from Safari and pasting it into Bear (on iPhone) still does create a hyperlink, which cannot be removed.

  10. Support Staff 10 Posted by Danilo Bonardi on 27 Jan, 2018 02:51 PM

    Danilo Bonardi's Avatar

    However, copying a URL from Safari and pasting it into Bear (on iPhone) still does create a hyperlink, which cannot be removed.

    Do You mean sharing an URL from the iOS extension? Apparently, I'm not able to simulate the title completion just by copying it.

  11. 11 Posted by Jean-Marc Le Ti... on 27 Jan, 2018 06:44 PM

    Jean-Marc Le Tissier's Avatar

    For this test I used the safari share menu and standard ‘copy’ option to simply copy, then pasted into Bear, rather than use the Bear extension.

  12. Support Staff 12 Posted by Danilo Bonardi on 29 Jan, 2018 10:43 AM

    Danilo Bonardi's Avatar

    @Jean Sorry, but I'm still failing to simulate this, can you please share which iOS version are you using? Thanks.

  13. 13 Posted by Jean-Marc Le Ti... on 29 Jan, 2018 02:16 PM

    Jean-Marc Le Tissier's Avatar

    Hi Danilo

    I can live with this particular behaviour because now the auto link geographic address is fixed, but I’m glad you want to fix this too. Good support :)

    Using iPhone 6+, iOS 11.2.2

    Here are the steps

    Go to any url in safari. E.g

    Use safari share sheet as per screenshot below

    Select copy (bottom left)

    Open Bear.

    Create new note


    Result is screenshot below. URL is a clickable link. Opens safari

    Since last time I tried this, there’s a new bug. You’ll notice the URL is incorrect. The second part is repeated. The link is still clickable but the url is, of course, 404 error. I don’t think this bug is a Bear problem because I got the same result in Drafts.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac