Bear Pro on iOS is always asking iTunes Password

vai's Avatar

vai

06 Nov, 2016 04:53 PM

I downloaded both Mac and iOS version and purchased the pro version.
It works fine on the Mac. But when I open the app on iOS device, It is always asking my iTunes credential.
All my devices are using the same AppleID and I see all my notes have been synced on all devices without inputing the password therefore I believe the password is not necessary for the sync.

It's annoying the popup box is blocking the UI and don't let me do anything. Clearly it's a bug and can be easily reproduce by downloading the app -> close the app -> re-open the app.

  1. Support Staff 1 Posted by Danilo Bonardi on 07 Nov, 2016 01:10 PM

    Danilo Bonardi's Avatar

    Hi,

    can you please try to reboot your device ? I suspect something weird is happening with the App Stores. Maybe also check if you are logged in the correct country on the Stores.

    Cheers.

  2. 2 Posted by vai on 07 Nov, 2016 07:19 PM

    vai's Avatar

    I rebooted my devices but the same issue still exists.

  3. Support Staff 3 Posted by Danilo Bonardi on 08 Nov, 2016 11:11 AM

    Danilo Bonardi's Avatar

    Can you check also if you have the iCloud Drive active on your devices ?

    http://www.bear-writer.com/faq/Sync/Sync%20Troubleshooting/

    Cheers.

  4. 4 Posted by vai on 08 Nov, 2016 11:23 AM

    vai's Avatar

    yes, iCloud drive is on.

  5. Support Staff 5 Posted by Danilo Bonardi on 08 Nov, 2016 02:26 PM

    Danilo Bonardi's Avatar

    Please, try to log out from the App Store on your iOS device, reboot, and log in again.

  6. 6 Posted by Harno on 25 Nov, 2016 08:50 AM

    Harno's Avatar

    I am having the same problem on iOS. I have rebooted my device, but it still keeps happening.

    I have not given it my iTunes credentials, but I don't want to until I've tried it out and decided if I like it. At the moment, it's making it really hard to do that.

  7. Support Staff 7 Posted by Danilo Bonardi on 25 Nov, 2016 09:48 AM

    Danilo Bonardi's Avatar

    Hi Harno,

    I suggest entering your iTunes credentials, we have not access to any of your information including your passwords. Every sensibile information remain between you and Apple

    http://www.bear-writer.com/faq/Sync/Syncing%20&%20privacy/

    Cheers.

  8. 8 Posted by Petros on 09 Dec, 2016 11:32 AM

    Petros's Avatar

    This comment was split into a new private discussion: Bear Pro on iOS is always asking iTunes Password

    H,i

    Same issue here. This issue makes me keeping distances from the app.

    Regards.

  9. 9 Posted by tonyc on 12 Dec, 2016 08:29 PM

    tonyc's Avatar

    I'm getting this behaviour on MacOS Sierra - at least one every launch or reboot of machine.

  10. 10 Posted by Scott Fi on 15 Feb, 2017 06:18 PM

    Scott Fi's Avatar

    +1

    I've been running Bear since Jan 2017 (iOS and MacOS) and only started experiencing this in the last week or so. I've logged out/in of app store a few times to no avail. Not sure what the deal is…

  11. 11 Posted by Scott Fi on 19 Mar, 2017 10:09 PM

    Scott Fi's Avatar

    I'm still having this issue. I've sent in emails to support and have gotten replies like "reboot the machine", "delete the app", and the most hilarious, "try logging in". Wow… never occurred to me to try logging in ಠ_ಠ

    Anyway, as I started Bear just now I noticed there is a "Debug" menu item (with an icon of a little top hat) that flashes up next to "Help" in the menubar. It's there for less than a second then disappears. I've never seen (or at least noticed) this behavior in any other app I've ever used.

    Thought I would pass this along in case it helps solve this maddening issue.

  12. Support Staff 12 Posted by Danilo Bonardi on 21 Mar, 2017 10:39 AM

    Danilo Bonardi's Avatar

    @Scott

    it's possible you are still using Bear beta or an unupdated version of Bear?

  13. 13 Posted by Scott Fi on 22 Mar, 2017 01:02 AM

    Scott Fi's Avatar

    @Danilo
      
      
      

      
    Thanks for the response. Nope, I've deleted it a couple times and reinstalled from Mac App Store. Since at this point this issue truly seems like an anomaly/outlier, I'm gonna play it safe and hit the SSD with Parted Magic and do a clean install. If it happens again though… you'll be the first to know 
      

      
    BTW I also wanted to congratulate you guys on the 1.1 update! I've only been able to spend a little time with it, but what I've seen so far is brilliant. I almost cried tears of joy when I tested out tag renaming. Great implementation. Also paragraph reordering, drag to tag. Y'all really went all out! I'm really looking forward to spending some more time with it 

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac